Please ensure that you have installed at least one of our supported browsers and that you have updated it to its latest version in order to run our simulations.

We currently only support:

Important: Safari and Edge are not supported. Some of our simulations currently present issues on Safari. While our team is working on fixing those, please use another one of our supported browsers.

Labster simulations do not run on the browsers mentioned above if you are using mobile devices such as smartphones and tablets.
 

Please do not hesitate to reach out to our support team if you have any questions or are in need of assistance. 

Did this answer your question?