If you only see a black screen after starting a simulation, or several objects are pink as in the screenshot below, then it could be because of 1) your graphic card drivers needs to be updated, 2) your computer is not meeting our minimum requirements, or 3) that there's an issue with your browser. 

Solution

To fix this, follow these steps, and try to load the simulation again after each step:

  • Disable Hardware Acceleration: This is the easiest way to try to fix this, and often solves this issue in just 5 minutes. Simply:
    1) open your browser settings,
    2) search for "Hardware Acceleration",
    3) turn off this feature, and
    4) relaunch your browser and try loading the simulation again.

    You can see a more detailed guide here.
  • Windows: Update your Graphic Card drivers: This is likely the best solution if you are on Windows. For Mac, please proceed to next step.
    If you are on Windows, please try following this guide to update your drivers.
     
  • Check minimum requirements: Ensure that your computer graphic card meets the minimum requirements listed here, and that your computer in general meets them.
  • Switch Browser: Switch to another browser and preferably either Chrome or Firefox. This means if the issue occurs in Chrome, then please start the simulation in Firefox. And if the issue occurs in Firefox, then please try using Chrome.
    Also, please make sure your browser is updated with the latest version.

 

Please do not hesitate to reach out to our support team if you have any questions or are in need of assistance. 

 

USEFUL LINKS:🚀

Looking for supported browsers? Checkout Firefox, Chrome or Safari 💬
Labster simulation system requirements? Please refer to this Specifications 💻Encounter any technical issue? Follow the basic labster troubleshooting 🔧
Want to get a demo of Labster? talk to us to better understand our Pricing 🔑
Want to get the latest insights from experts? Please go to Webinars 📣
Want to discover new ways of teaching and learning? check out Labster blog 📚
Want to know the latest news from Labster ? please sign up to our newsletter 💌

SOCIAL MEDIA LINKS:🌍™

Check out our Website
Follow us on Instagram
Like us on Facebook
Tweet with us on Twitter
Subscribe to our official Youtube channel

Want to know more?🔎

👉 Basic Labster Troubleshooting
👉 Pressing Start shows Resume button: Simulation doesn't start
👉 Loading Stops at 0% within an iframe
👉 Loading error at 25% progress: Antivirus Blocking Labster
👉 Stuck on teleporting screen
👉 Red Screen on Mac in Safari/Firefox
👉 Loading difficulties
👉 Stuck in a simulation? Quick tips here
👉 Out of Memory error message
👉 Media won't work in Safari
👉 Missing element
👉 View Theory button is blank 

If you'd like to know more, chat to us in the Messenger 😊

Did this answer your question?