Safari blocks media with sound by default. You can change that by updating a simple parameter:

1. In your Safari browser window, on the top, click on Safari > Preferences

2. On the top menu, navigate to the tab Websites and on the right hand-side, select Auto-Play

3. Click on the drop-down menu next to 'When visiting other websites' and select the option 'Allow All Auto-Play'.

You should now be able to play and hear all the media available in the simulations.

Alternatively, you can use any other of our supported browsers.
 

Please do not hesitate to reach out to our support team if you have any questions or are in need of assistance. 

 

USEFUL LINKS:🚀

Looking for supported browsers? Checkout Firefox, Chrome or Safari 💬
Labster simulation system requirements? Please refer to this Specifications 💻Encounter any technical issue? Follow the basic labster troubleshooting 🔧
Want to get a demo of Labster? talk to us to better understand our Pricing 🔑
Want to get the latest insights from experts? Please go to Webinars 📣
Want to discover new ways of teaching and learning? check out Labster blog 📚
Want to know the latest news from Labster ? please sign up to our newsletter 💌

SOCIAL MEDIA LINKS:🌍™

Check out our Website
Follow us on Instagram
Like us on Facebook
Tweet with us on Twitter
Subscribe to our official Youtube channel

Want to know more?🔎

👉 Basic Labster Troubleshooting
👉 Pressing Start shows Resume button: Simulation doesn't start
👉 Loading Stops at 0% within an iframe
👉 Loading error at 25% progress: Antivirus Blocking Labster
👉 Stuck on teleporting screen
👉 Red Screen on Mac in Safari/Firefox
👉 Loading difficulties
👉 Stuck in a simulation? Quick tips here
👉 Out of Memory error message
👉 Black screen when entering a simulation
👉 Missing element
👉 View Theory button is blank 

If you'd like to know more, chat to us in the Messenger 😊

Did this answer your question?